Anypoint Platform Release and Maintenance Window
Scheduled for Jul 18, 10:00 - 15:00 PDT
Update
On Thursday, July 18, 2024 between 10AM and 3PM PDT (1PM - 6PM EDT, 5PM-10PM UTC)

Customer Impacting / Downtime Announcement(s)


*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be performing a scheduled update Vulnerability Remediation of an internal database for email notifications
*** Service impact details:
** Applications:
Runtime Manager
API Manager
Composer
CloudHub
During maintenance downtime:
* User Experience(UX): Email notification system will be unavailable.

*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be performing a scheduled upgrade of an internal database for Anypoint Secrets Manager
*** Service impact details:
* Applications:
- Runtime Manager
- API Manager
- Partner Manager
- Anypoint Security (All components)
- Design Center (API Designer and Design Center Projects)
- Anypoint Monitoring
- MuleSoft Composer
During maintenance downtime:
* User Experience(UX): Anypoint Secrets Manager will be unavailable. User will experience an error for the following applications:
Anypoint Secrets Manager: Customers will not be able to manage secret groups and secrets.
Runtime Manager: Customers will not be able to deploy a new mule application, create a new Runtime Fabric instance, Private Space instance and Tokenization Service.
API Manager: Customers will not be able to add or update APIs using Mule Gateway or Flex Gateway.
Partner Manager: Customers will not be able to create or update endpoints, nor they will be able to deploy new message flows. Also they won’t be able to run template upgrades.
Anypoint Security: Customers will not be able to create or update their security-edge instance and tokenization service.
Design Center: Customers will not be able to perform activities involving Anypoint Secrets Manager.
Anypoint Monitoring: Customers monitors that are using Anypoint Secrets Manager integration in their monitor will fail.
MuleSoft Composer: Customers will not be able to activate flows. Existing flows may also be impacted if it stores or retrieves secrets from Secrets Manager.
* API calls:
Invoking Anypoint APIs that use Anypoint Secrets Manager will fail.
* Existing Runtimes: are not impacted.
* Following maintenance downtime:
Anypoint Secrets Manager will function as usual

*** ATTENTION: up to 45 minutes service interruption is expected during this maintenance window ***

We will be performing a scheduled upgrade on part of the platform's underlying public key infrastructure.
*** Service impact details:
* Applications:
- Runtime Fabric and CH2 spaces
- Anypoint Monitoring
- Flex Gateway
- RPA
During maintenance downtime:
* Runtimes: are not impacted.
* User Experience(UX):
1. Existing Runtime Fabric agents cannot rotate the PKI certificate. New Runtime Fabric installation cannot be created.
2. Anypoint monitoring agent will not be able to renew its mTLS certificate. There is no impact to the usage of existing mTLS certificate to ship the metrics to the Anypoint platform, unless the certificate expires during the maintenance window.
3. mTLS certificate for existing Flex Gateway instances cannot be renewed. Existing Flex Gateway instances cannot be deleted. New Flex Gateway instance cannot be created.
4. RPA manager will only be affected if its multi-tenant infrastructure needs to be expanded to fulfill a new provisioning request during the maintenance window.
* API calls: API calls will not be impacted.

*** ATTENTION: up to 10 minutes of service interruption is expected during this maintenance window ***

We will be doing a scheduled upgrade on part of the platform underlying infrastructure.
*** Service Impact Details:
* Applications:
- RPA Runtime
During maintenance downtime:
- RPA Runtime No data loss is expected for any tenant. Execution of RPA processes may fail intermittently as the infrastructure upgrade is in progress.
Following maintenance downtime:
- RPA Runtime will resume normal operations.

*** ATTENTION: up to 5 minutes of service interruption is expected during this maintenance window ***

We will be performing an update to the certificates of each Access Management database.
*** Service Impact Details:
** Applications:
- Access Management
- Help Center
During maintenance downtime, the following may fail:
- API calls to Access Management
- Logging into Anypoint Platform
- Creating or updating organizations
- Inviting or updating users
- Creating or updating teams
- Creating or updating environments
- Configuring or updating multi-factor authentication
- Configuring or updating identity providers
- Creating or updating connected apps
- Creating access tokens
- Authorizing permissions and resources
- Authenticating clients and access tokens
- Getting organization information
- Getting user profiles
- Mule Gateway: There may be errors in customer logs and disconnections, but gateways will continue serving traffic.
Following maintenance downtime
- Access Management will function as usual
- Help Center will function as usual
Additionally, the following services may be impacted and in degraded states during this change. It is recommended that customers treat the following services as degraded during this window:
- AMF Service
- Anypoint Metering
- Anypoint Monitoring
- Anypoint MQ
- API Analytics
- API Designer
- API Functional Monitoring
- API Manager
- API Mocking Service
- API Monitoring Center
- Audit Log
- Design Center Projects
- Mule Gateway
- Object Store V2
- Runtime Manager
- Anypoint Visualizer

*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be doing a scheduled upgrade on part of the platform underlying infrastructure.
*** Service Impact Details:
* Applications:
- MuleSoft Composer
During maintenance downtime:
- Composer UI will be intermittently inaccessible including Flow editor and Run History. Activating new flows may fail intermittently.
Following maintenance downtime:
- Composer functionality will resume normal operations.

*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be performing database maintenance.
*** Service Impact Details:
** Applications:
Usage Reports (Metering)
During Maintenance Downtime:
User Experience(UX): Anypoint Platform users may not be able to view their Usage Reports.
Usage will continue to be collected.
Following maintenance downtime:
Anypoint Platform users will be view their Usage Reports as usualWe will be undergoing scheduled maintenance during this time.
Posted Jul 09, 2024 - 11:27 PDT
Scheduled
On Thursday, July 18, 2024 between 10AM and 3PM PDT (1PM - 6PM EDT, 5PM-10PM UTC)

Customer Impacting / Downtime Announcement(s)


*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be performing a scheduled update Vulnerability Remediation of an internal database for email notifications
*** Service impact details:
** Applications:
Runtime Manager
API Manager
Composer
CloudHub
During maintenance downtime:
* User Experience(UX): Email notification system will be unavailable.

*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be performing a scheduled upgrade of an internal database for Anypoint Secrets Manager
*** Service impact details:
* Applications:
- Runtime Manager
- API Manager
- Partner Manager (both v1 and v2)
- Anypoint Security (All components)
- Design Center (API Designer and Design Center Projects)
- Anypoint Monitoring
- MuleSoft Composer
During maintenance downtime:
* User Experience(UX): Anypoint Secrets Manager will be unavailable. User will experience an error for the following applications:
Anypoint Secrets Manager: Customers will not be able to manage secret groups and secrets.
Runtime Manager: Customers will not be able to deploy a new mule application, create a new Runtime Fabric instance, Private Space instance and Tokenization Service.
API Manager: Customers will not be able to add or update APIs using Mule Gateway or Flex Gateway.
Partner Manager: Customers will not be able to create or update endpoints, nor they will be able to deploy new message flows. Also they won’t be able to run template upgrades.
Anypoint Security: Customers will not be able to create or update their security-edge instance and tokenization service.
Design Center: Customers will not be able to perform activities involving Anypoint Secrets Manager.
Anypoint Monitoring: Customers monitors that are using Anypoint Secrets Manager integration in their monitor will fail.
MuleSoft Composer: Customers will not be able to activate flows. Existing flows may also be impacted if it stores or retrieves secrets from Secrets Manager.
* API calls:
Invoking Anypoint APIs that use Anypoint Secrets Manager will fail.
* Existing Runtimes: are not impacted.
* Following maintenance downtime:
Anypoint Secrets Manager will function as usual

*** ATTENTION: up to 45 minutes service interruption is expected during this maintenance window ***

We will be performing a scheduled upgrade on part of the platform's underlying public key infrastructure.
*** Service impact details:
* Applications:
- Runtime Fabric and CH2 spaces
- Anypoint Monitoring
- Flex Gateway
- RPA
During maintenance downtime:
* Runtimes: are not impacted.
* User Experience(UX):
1. Existing Runtime Fabric agents cannot rotate the PKI certificate. New Runtime Fabric installation cannot be created.
2. Anypoint monitoring agent will not be able to renew its mTLS certificate. There is no impact to the usage of existing mTLS certificate to ship the metrics to the Anypoint platform, unless the certificate expires during the maintenance window.
3. mTLS certificate for existing Flex Gateway instances cannot be renewed. Existing Flex Gateway instances cannot be deleted. New Flex Gateway instance cannot be created.
4. RPA manager will only be affected if its multi-tenant infrastructure needs to be expanded to fulfill a new provisioning request during the maintenance window.
* API calls: API calls will not be impacted.

*** ATTENTION: up to 10 minutes of service interruption is expected during this maintenance window ***

We will be doing a scheduled upgrade on part of the platform underlying infrastructure.
*** Service Impact Details:
* Applications:
- RPA Runtime
During maintenance downtime:
- RPA Runtime No data loss is expected for any tenant. Execution of RPA processes may fail intermittently as the infrastructure upgrade is in progress.
Following maintenance downtime:
- RPA Runtime will resume normal operations.

*** ATTENTION: up to 5 minutes of service interruption is expected during this maintenance window ***

We will be performing a scheduled upgrade of an internal Access Management database.
*** Service Impact Details:
** Applications:
- Access Management
- Help Center
During maintenance downtime, the following may fail:
- API calls to Access Management
- Logging into Anypoint Platform
- Creating or updating organizations
- Inviting or updating users
- Creating or updating teams
- Creating or updating environments
- Configuring or updating multi-factor authentication
- Configuring or updating identity providers
- Creating or updating connected apps
- Creating access tokens
- Authorizing permissions and resources
- Authenticating clients and access tokens
- Getting organization information
- Getting user profiles
- Anypoint MQ: If an existing token expires, the MQ Connector may experience HTTP 5XX errors for a few minutes, particularly if Access Management returns 5XX errors during the upgrade.
- Mule Gateway: There may be errors in customer logs and disconnections, but gateways will continue serving traffic.
Following maintenance downtime
- Access Management will function as usual
- Help Center will function as usual
Additionally, the following services may be impacted and in degraded states during this change. It is recommended that customers treat the following services as degraded during this window:
- AMF Service
- Anypoint Metering
- Anypoint Monitoring
- Anypoint MQ
- API Analytics
- API Designer
- API Functional Monitoring
- API Manager
- API Mocking Service
- API Monitoring Center
- Audit Log
- Design Center Projects
- Mule Gateway
- Object Store V2
- Runtime Manager
- Anypoint Visualizer

*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be doing a scheduled upgrade on part of the platform underlying infrastructure.
*** Service Impact Details:
* Applications:
- MuleSoft Composer
During maintenance downtime:
- Composer UI will be intermittently inaccessible including Flow editor and Run History. Activating new flows may fail intermittently.
Following maintenance downtime:
- Composer functionality will resume normal operations.

*** ATTENTION: up to 60 minutes of service interruption is expected during this maintenance window ***

We will be performing database maintenance.
*** Service Impact Details:
** Applications:
Usage Reports (Metering)
During Maintenance Downtime:
User Experience(UX): Anypoint Platform users may not be able to view their Usage Reports.
Usage will continue to be collected.
Following maintenance downtime:
Anypoint Platform users will be view their Usage Reports as usual
Posted Jul 08, 2024 - 14:11 PDT
This scheduled maintenance affects: Anypoint Management Center (Access Management, API Manager, Runtime Manager, API Analytics, API Functional Monitoring, Audit Log), Anypoint MQ (Anypoint MQ - Admin - eu-central-1, Anypoint MQ - Stats - eu-central-1, Anypoint MQ - Broker - eu-west-1, Anypoint MQ - Broker - eu-west-2), Object Store v2 (Object Store v2 - Stats - eu-central-1, Object Store v2 - Service - eu-central-1, Object Store v2 - Service - eu-west-1), Runtime Services (Runtime Fabric), Anypoint Security (Secrets Manager, Security - Edge, Tokenization), Design Center (API Designer, API Mocking Service), and Anypoint Partner Manager v2, Anypoint Visualizer, MuleSoft Composer, MuleSoft Help Center, MuleSoft RPA, Anypoint Monitoring.