API Manager is failing to apply new policies to applications.
Incident Report for EU1 - Anypoint Platform
Resolved
As of 10:23 UTC, the impact to API Manager is resolved. API Gateway is now able to retrieve and apply all the configured policies.

API Gateway might continue to show errors for the application of previous versions of the policy but this has no impact on the gateway and the errors will disappear with a restart.
Posted Mar 05, 2024 - 03:19 PST
Monitoring
We have deployed a fix for this issue to the production environment, after validating it in our lower environments. We are monitoring the effectiveness of the fix, and expect error rates to return to pre-incident levels within the next 60 minutes.
Posted Mar 04, 2024 - 23:26 PST
Identified
We have addressed the backend issue causing the errors that have generated this incident, while we work on restoring the service fully, we have identified a remediation step that can be taken to restore your applications to their expected performance.

If your Mule Gateway is currently affected, proceed to restart your Mule Runtime.

If you are unsure if your gateway is currently affected, you can review the logs to see if there is any occurrence of an error message like:

Error deploying policy to application
com.mulesoft.mule.runtime.gw.policies.template.exception.PolicyTemplateAssetException: Unexpected error when requesting template metadata for

If you see occurrences of the above error message then you should proceed to restart your Mule Runtime.
Posted Mar 04, 2024 - 20:36 PST
Update
We are continuing to investigate the issue, we are now seeing impact on existing applications without changes to policies. Please provide specifics in your customer case if you are experiencing issues with your applications.
Posted Mar 04, 2024 - 19:27 PST
Update
We are continuing to investigate this issue, and are working on a set of steps to address the situation. Once confirmation of those steps has been accomplished we will update.
Posted Mar 04, 2024 - 18:53 PST
Update
Existing applications with the policies will continue to operate smoothly. However, in the event of application restarts or when deploying new apps, there is a risk that they may encounter difficulties in downloading and applying API Manager policies, resulting in deployment failures.
Posted Mar 04, 2024 - 16:14 PST
Update
We are continuing to investigate this issue.
Posted Mar 04, 2024 - 16:06 PST
Investigating
Customers may experience errors while using applying new policies to existing and new applications. Our teams are investigating.
Posted Mar 04, 2024 - 14:57 PST
This incident affected: Anypoint Management Center (API Manager).